Bootstrap-Bootstrap 4のbootstrap.jsでUncaught Errorが発生した場合に対処する


記事の要約

Bootstrap 4のbootstrap.jsでUncaught Errorが発生した場合に対処する方法です。
Bootstrap 4のアルファ版を使用する際に、javascriptを読み込むとエラーが発生します。
エラー内容は以下の通りです。
「Uncaught Error: Bootstrap tooltips require Tether(http://tether.io/)」

Uncaught Error: Bootstrap tooltips require Tether

今回はBootstrap 4の Tooltip において必要としている
スクリプト Tether を読み込みさせることでエラーを回避します。


jQuery

// Tether
// 注意: Bootstrap 4より先に読み込みさせること
<script src="https://npmcdn.com/tether@1.2.4/dist/js/tether.min.js"></script>

// Bootstrap 4
<script src="https://maxcdn.bootstrapcdn.com/bootstrap/4.0.0-alpha.6/js/bootstrap.min.js"></script>

Bootstrap 4

v4-alpha.getbootstrap.com